Monday, February 17, 2014

Analysis of a repeater's antenna pattern

Back in 1997 the antennas on the Utah Amateur Radio Club's 146.760 repeater were relocated and replaced - this, because the original, guyed tower on which the antennas were located was being replaced by a free-standing 120' tower.

Because the (separate) transmit and receive antennas were, at that time, over 20 years old (but still in perfect condition owing to radome placed over them when they were originally installed) we decided to start anew with the 2 meter antennas, putting the new antennas at the locations prescribed by the owner:  The receive antenna on top at the 120 foot level and the transmit antenna at the 60 foot level.  Upon installing the new antennas and running the new Heliax (tm) in a cable tray with almost nothing else in it (yet) we noted that we were the first to attach anything to the (also) brand-new ground system.  (We also noted that some hardware for part of the ground system had been installed incorrectly - which we fixed!)

While the receive antenna - being the tallest thing on the tower - worked quite well we could tell that something was amiss with the transmit antenna.  From the time that it had been installed we got reports that the signals to the north were noticeably weaker than they had been on the old tower/antenna and anecdotally, they seemed to get worse as the tower was finally built-up and more antennas, dishes and cables were gradually installed over the years.

Reading
(HEX)
SSB/CW/AM
signal strength
(dbm)
FM
signal strength
(dbm)
0 <-108 <-114.5
1 >-108.3 >-113.8
2 >-107.3 >-113.0
3 >-106.7 >-111.6
4 >-106.0 >-110.2
5 >-105.1 >-108.8
6 >-104.2 >-106.4
7 >-103.0 >-104.7
8 >-100.4 >-102.8
9 >-84 >-101.0
A >-74.5 >-99.5
B >-70.1 >-97.8
C >-58.9 >-96.8
D >-50.8 >-95.8
E >-40.8 >-94.6
F >-30.1 >-93.5
Table 1
Serial-port S-Meter readings versus signal input (as read via the serial port) on 2 meters for my FT-817 as shipped from the factory.
Not wanting to rush into these things, it wasn't until 2001 that we decided to make some scientific measurements.  One option was to drag along a signal level meter or spectrum analyzer and, every so-often, stop and make signal level measurements.  Since this method was likely to be very tedious and, in some areas may not even be very practical, I decided that there had to be a better way!

The FT-817 as a test instrument:

Not too long before this I'd bought a Yaesu FT-817 and noticed that it had the capability of reading the S-Meter via the serial port, but it had a rather useless signal strength span when it came to making meaningful measurements of real-world repeaters.

As can be seen from TABLE 1 the readings aren't entirely useful.  While each step is approximately 1 dB (more or less) the useful range goes from -114.5 to about -93.5 dBm - this entire range being generally weaker than what one might see from a local repeater.  At the same time I also made measurements of the S-meter reading when in SSB/CW/AM mode to see if that would be useful and while it covered far more range, the steps were uselessly small at the weak signal end (e.g. <1dB) but uselessly large at the high-signal end! (This indicates another, well-known problem with the FT-817's AGC, but that's another story...)

At about this same time I'd become interested in another aspect of the FT-817:  It's "soft" calibration settings.  I believed that these settings, in a special "calibration" menu, were too numerous and tedious to have someone on an assembly line adjust so I figured that there MUST be a way in which a radio was semi-automatically calibrated at the factory - and I was right!

What I found were some "undocumented" commands via the serial port - some of which obviously read from and wrote to the EEPROM - and I quickly wrote a program that would allow me to determine what memory locations were used for what:  The program would download the current EEPROM content, I would change a setting, and then the program would tell me what had changed after downloading it again.  I'd documented my findings on a web page and in the years that followed, all sorts of things followed-on from this information (e.g. "FT-817 Commander", the "SoftJump" program, various remote meters for FT-817 signal strength, ALC, SWR and transmit power - just to name a few).
 
Reading
(HEX)
FM
Signal
Strength
(dbm)
Reading
(HEX)
FM
Signal
Strength
(dbm)
0 <-110.7 8 -94.2
1 -108.9 9 -91.5
2 -106.2 A -89.2
3 -104.2 B -87.2
4 -102.3 C -85.2
5 -100.6 D -82.1
6 -98.9 E -78.1
7 -96.7 F >-75.7
Table 2
Serial-port S-Meter readings versus signal input using FM mode (as read via the serial port) after the described recalibration of the FM-S1 and FM-FS parameters. 
In  this early stage there were two "Soft Calibrate" (and now, EEPROM) settings that most interested me:  The ones that corresponded with S-Meter calibration, namely #9 - "FM-S1" and #10 - "FM-FS" which, I correctly surmised, related to the settings for the S1 and Full-Scale readings.  Through experimentation by using a calibrated signal generator and observing the readings on the serial port I determined that the original settings badly shortchanged the dynamic range of the FM S-meter and simply by readjusting these two settings could provide a wider and more useful FM S-Meter range as TABLE 2 demonstrates.

Now the meter was useful over a range of more than 30 dB and it still had reasonable resolution - between 2-3dB per step, but I still had a problem:  The usable range - from about -108 dBm to about -80dBm was still too low for the expected signal strength of typical, local repeaters which could vary from about -50 to -80 dBm at the receiver's input terminal.

Fortunately, I knew of another setting or two within the radio that proved to be useful - Calibration menu # 5 "VHFRXG".  This setting adjusted the bias of a PIN diode in the FT-817's IF and I found that it could usefully add at least 30 dB of attenuation, extending the S-meter to signals stronger that -50dBm!

What was more, I found that this setting - because it was done in the IF - was the same for every band (using the corresponding calibration points for HF, 6 meters and UHF) and it turned out to be consistent (within a 2-3dB) over a very wide temperature range (e.g. "Hot Car" to "Deep Freeze").  I found three more values for the "xxxRXG" parameter that adjusted the gain by approximately 10 dB (and precisely measured that amount of attenuation) and was ready to go!
 
Reading
(HEX)
VHFRXG
99
VHFRXG
57
VHFRXG
49
VHFRXG
43
0 <-110.7 <-98.5 <-88.1 <-78.7
1 -108.9 -96.8 -86.7 -77.7
9 -91.5 -79.5 -69.6 -60.4
D -82.1 -70.5 -60.2 -50.9
E -78.1 -66.3 -56.5 -46.9
F >-75.7 >-63.8 >-53.6 >-44.5
Average 
Difference 
(db)
 - 12.0 22.0 31.1
Table 3
Sample values of the VHFRXG parameter (soft calibration menu item #5) versus the signal input level.  The bottom row shows the average difference between the "unattenuated" reading (VHFRXG = 99) versus the reading obtained with differing amounts of "attenuation".
Note:  The above values are for my FT-817.  Every '817 will be different, requiring individual calibration to assure accuracy.

Putting it all together:

I could now get down to the business of writing a program that would take all of this data and make sense out of it.

What I had now were lots of bits of information that I could use to analyze the problem related to the repeater's transmit coverage:
  • Using the FT-817, I could now read the signal level arriving at its antenna terminal.
  • Knowing the type of antenna and amount of coax, I could make an estimate of antenna gain and other losses to correct the signal level reading.
  • The GPS location of the repeater was known from previous on-site measurements.
  • The repeater's transmit antenna gain and losses (coax, cavity, etc.) were known.
  • Using a portable GPS receiver connected to the computer, I knew MY location via the NMEA strings emitted by a GPS receiver and fed to the computer.  The laptop that I was using had only one serial port so I used a relay controlled by the handshake line two switch between the FT-817 and the GPS receiver every 30 seconds or so to record the location.
  • Knowing my location with respect to that of the repeater, I could calculate the distance between my antenna and the repeater's antenna as well as the bearings to/from the two antennas.
  • Using fairly simple formulas, I could calculate the free-space path loss between my current location and the repeater antenna.
  • Knowing the transmit antenna gain and loss parameters, my own receiver's antenna gain and loss parameters and the amount of expected path loss, I could could calculate how much signal I should (theoretically!) expect from the repeater.
  • Since I was able to directly measure my received signal strength, I could calculate the "Excess Path Loss" - that is, the difference between the predicted signal level and the actual signal level.  This value could vary from being negative, indicating a higher signal level than expected, to positive, indicating greater path loss than expected.  Both a "real-time" and a "sliding average" reading were made available, the latter smoothing out short-term variations in signal level due to Fresnel effects, uncertainty in measurements and the effects of nearby obstructions such as buildings and vehicles.
  • Since it was a computer, this was done automatically and the results saved to a text file for later analysis.  This included time stamps and all of the raw data as well as the "cooked" data such as excess path loss, bearing to/from the site, etc.
  • The program also allowed brief text notes to be inserted in the file permitting one to take notes about local obstacles that might skew readings, etc.
What this meant was that while I drove a path that circumnavigated the 146.760 repeater, my passenger could look at the computer's screen which was providing a real-time display of the calculated parameters.  The biggest advantage was that we could be zooming down the highway, taking readings very frequently.  With the real-time display we could also take a different route if we suspected that some local obstructions excessively skewed the readings.

So, during April 2001 - after testing the program on a few other local repeaters and finding that the readings agreed within a few dB of theoretical - Gordon, K7HFV and myself took a day-long drive, circumnavigating the 146.76 repeater.  While much of this was via paved roads there was a significant segment consisting of high-clearance four-wheel drive dirt and gravel roads that took more time to traverse than the rest of the trip put together!

Having made the trip "behind" Lake Mountain to the west we were coming close to closing the circle when, while driving along the highway, Gordon started reading out "additional path loss" numbers like "-10... -15... -25... -35... -25... -15... -10..."  While in full, line-of-sight view of the transmit antenna we had passed through a 30+ dB deep null in the transmit pattern while traveling a fairly short distance!  Not sure of what we just saw, I did a legal U-turn and re-traced the path going the other way - and then back again, each time seeing the same numbers go by on the display on three occasions!

Figure 1: 
The measured antenna pattern (the shaded circle near the center) and the calculated coverage of the 146.760 repeater based on this pattern and actual terrain data.
Click on the image for a larger version.
We now had our answer as to how severe the null was - and the results may be seen in Figure 1.  After analyzing the logged data I was able to determine the approximate antenna pattern and input this data into the "RadioMobile" program by VE2DBE.  As expected, it showed a rather deep null almost exactly straight north, encompassing a significant portion of the Salt Lake valley and communities to the north.

What to do about the null?

Even though we've known about this problem for some time now, the big question is "What to do about it?"  On this site, the receive antenna is just that:  A receive-only antenna, and we cannot transmit from that location - which, being on the top of the tower, is free of this null.  At the level of the transmit antenna we have the problem of there being very limited options as to where and how we may mount our antenna to avoid the mechanical obstacles.  We have some ideas in mind, but we are still considering the options!

A slightly more in-depth version of this article may be found here (link).

For more information about the FT-817's inner workings, visit the KA7OEI FT-817 pages (link)


Update:

In the fall of 2014 a "fill" antenna was added to (hopefully) minimize the null caused by the "tower clutter".  While anecdotal evidence indicates that this has improved coverage in the "null zone", at the time of this update (3/15) we have yet to re-do at least part of the circumnavigation to quantify the effect of this change.

[End]

This page stolen from ka7oei.blogspot.com

Saturday, February 8, 2014

Low Pass filter for MF/LF (600 meter) reception

About a month ago I fired up the SDR-14 (a wide-bandwidth software-defined "receiver") to "listen" to some longwave signals from some (relatively) high-power stations back east.  These stations had obtained FCC Part 5 authorization to transmit on or about 74, 137 and around 470 kHz (yes, kiloHertz!) but it also included FCC Part 15 operations between 160 and 190 kHz, the so-called "LowFER" band.  With the Part 5 operators typically running several hundred watts of RF into their antennas, the low frequencies (for 74 and 137 kHz, at least - 470 kHz is a bit more manageable) meant that they were radiating mere watts - if they were lucky.  Since others in the continental U.S. and a few in Europe were receiving those signals I decided to dust off some of my LF/VLF receive gear and see if I could "hear" them.

I put "listen" and "hear" in quotes as most of these transmissions have been using very slow CW ("QRSS") and/or some very slow digital modes (OPERA, WSJT and WOLF) to transmit their signals. Using these techniques, audio from a receiver would be piped into a computer and detected/decoded at signal/noise levels far below those at which they could be detected by the human ear.

Antenna problems:

Many years ago (in 1986 or 1987) I bought an LF Engineering LF-400B E-field active whip antenna.  While not necessarily a top-of-the-line performer compared to some active antennas these days that use some rather "interesting" circuits to obtain good dynamic range and bandwidth, this whip's claim to fame is that it has a half-decent low pass filter built into it and is able to handle fairly strong, nearby AM broadcast stations without wilting and causing intermodulation distortion.  In my use of this antenna over the years I have had little cause to complain about its performance on that regard.

At my present QTH this antenna has been on the roof for about 15 years and it had worked every time I'd powered it up but on this day, the first time that I'd powered it up in a few months, I heard nothing other than an elevated noise floor and observed the inability to hear all but the strongest signals such as the powerhouse VLF stations run by the U.S. Navy in the 20-30 kHz range in Washington State and WWVB on 60 kHz in Fort Collins, Colorado.

Braving the ice on my roof I retrieved the antenna and opened it up to see what was wrong.  Other than some obvious exposure to moisture at some point - probably due to condensation that had not caused any electrolytic damage since the unit was not left powered up at all times - it looked pretty good.  Touching the gate of the FET on the front end brought a roar of noise but touching anything on the input filter past the second inductor resulted in practically no change.

Removing the three 10 mH inductors in the front end filtering, I put them on test equipment.  The first one in line with the antenna was open, the middle one had much higher than expected (and varying) DC resistance and terrible Q while the one closest to the FET seemed to be OK.  Inspecting them under a magnifier I noticed that on each of them, the epoxy potting the winding and the core seemed to have shrunk away from the plastic, outer casing on all of the inductors, as well as around the leads as they entered the coil.  I can only guess that the thermal cycling of the antenna from well below freezing to hot summer days in the sun, on the roof - along with moisture - must have gradually infiltrated the coils' potting material and broken them down.

Rummaging around I didn't find find an exact match, but only some 27 mH inductors from the same manufacturer and product line (same color, size, etc.) as the originals so I put those in, instead, tested the antenna indoors, re-sealed it, and then put it back on the roof.  Turning on the receiver I was greeted with very strong signals, some 40dB or so stronger than they had been before!  What I also noticed was that I was now experiencing some intermodulation distortion from some of the local AM broadcast stations that I'd not noticed the last time I'd used the antenna.

Simulating the antenna's front end filter using LTSpice I was somewhat surprised to notice that simply replacing the 10mH inductors with 27mH inductors resulted in a worse low-pass response than the original:  I had sort of expected that more than doubling the inductance would have just dropped the low-pass cut-off frequency.  This filter response degradation, allowing the AM broadcast stations to get through better, possibly explained my problems with intermod.

Not sure if it was the SDR-14 or the antenna I threw together the bandpass filter depicted schematically below to place on the output, in front of the receiver:

Figure 1:
Schematic diagram of the (approx.) 500 kHz low-pass filter that could be used for reception at "600 meters."
This filter is intended to be sourced/terminated at 50 ohms.
This filter is bilateral - that is, the input and output are interchangeable.
Click on the image for a larger version.


Initially consulting the low-pass filter tables in an ARRL Amateur Radio Handbook and rescaling the values for the desired frequency, I entered the filter in LTSpice and juggled standard inductor and standard capacitor values that I had in my parts collection until I found a design that was a reasonable performer using more-or-less standard components.  The design of the filter itself is an "Elliptical" filter that includes "notches" to more-quickly achieve a low-frequency cut-off using fewer sections than might be achieved with a "standard" filter such as a Butterworth or Chebychev - this, at the expense of a bit of ripple and ultimate rejection at higher frequencies.

The filter itself was built "dead bug" on a scrap piece of copper-clad circuit board material and then frequency-swept using a function generator with a 50 ohm output, an oscilloscope in parallel with a 50 ohm load and also with a homebrew signal level meter based on an AD8307 logarithmic amplifier chip that also presents a 50 ohm load.

Based on the two methods of measuring the filter attenuation (the 'scope and the meter - both of which actually agreed!) I found that measured attenuation was reasonably close to what had been predicted, achieving at least 50 dB above about 685 kHz:  Not too bad for just a few minutes of number crunching, component tolerances, and the rather mediocre performance of some of these small chokes!

Figure 2:
The completed 500 kHz low-pass filter.  Plastic capacitors should be used, but if you use ceramic units be certain that
they are NPO (C0G) types!  The 22uH chokes were small, molded devices while I happened to have
a different (solenoid) style for the 27uH choke.
Click on the image for a larger version.

Placing the filter in series with the receiver I noticed.... No change in the amount of interference.

My guess is that the "temporary" inductors in the active antenna have compromised the low-pass filter performance of the active antenna enough that its amplifier is being driven to distortion - either that, or one of the transistors or diodes has somehow degraded:  Some new inductors of the same style as the old are on my "running" list of parts next time I place an order.

Comment:
When I first installed the LF-400B E-field whip antenna antenna at my present QTH I heard intermodulation products from several local AM broadcast stations, but soon discovered that it was occurring due to nonlinear effects in the final amplifier stage of a low-power FCC Part 15 ("MedFER") beacon transmitter only a few feet away.  Disconnecting its antenna made the problem go away.
That wasn't the case, this time!


What is this filter good for?

If I were to use an antenna such as a long-wire or a wide-band active whip antenna that doesn't have built-in filtering, the aggressive roll-off of the AM broadcast band offered by this filter would keep these strong signals from clobbering the receiver - a common problem with many amateur-band transceivers and receivers that include coverage of this frequency range!

In some parts of the world there currently are amateur allocations around 137 kHz and/or in the 400-520 kHz area:  An amateur allocation in the 470-480 kHz range (the so-called "600 Meter" band) in the U.S. is being considered and a filter such as this would be necessary for many existing communications receivers!

As designed, this filter is not suitable for transmitting - at least at anything more than a few 10's of milliwatts - mostly owing to the inherent lossiness of the small, molded inductors and the fact that its cutoff frequency is a bit low, possibly including frequencies of interest:  On receive the 3-6dB loss would hardly be noticed at these frequencies but would be prohibitive for a high-level transmitter stage!

I'll keep this filter around:  It hardly cost me anything to make and it may come in handy if we ever do get a "600 meter" amateur band!  (I may even put it in a box.)

* * *

Did I ever hear the signals from back east once I got my antenna working?

Yes, actually:   While the intermod is annoying, it's not too crippling.  I got a pretty good signal from a station (WG2XRS/4) on 74.3211 kHz in New York state - a distance of approximately 1560 miles (2900 km).  I also received a number of stations around 137 kHz from both Canada and the U.S.

Follow-up on the LF-400B:

I finally did get around to replacing the 10 mH inductors on the input of my LF-400B active E-field whip.

While the original manufacture of inductors were no longer available from Mouser, I did get some Fastron 07MFH-103F-50 units (from Mouser) which were the same size - although lacking what appeared to have been the thin ABS or PVC exterior case if the original and were about a millimeter smaller in diameter.

Upon replacement of the (temporary) 27 mH inductors with these 10 mH inductors, the intermodulation problems went away and the LF-400B antenna is once again working as it should!


[End]

This page stolen from ka7oei.blogspot.com

Sunday, February 2, 2014

First foray into the world of Arduino

Before Christmas I was ordering a few things from Amazon and was somewhat surprised when I was unable to check out with a few smaller items that completed the order.  Puzzled, I dug around and discovered that there was, in effect, a minimum order for some items - something that I'd not known about Amazon - and unless I exceeded it, there seemed to be no way to order them.

Not sure what else that I wanted at that last moment it occurred to me to get an Arduino Uno and I was able to check out with all of the items.

I had it around for about a month before I got around to doing anything with it other than make it blink an LED.  In looking at the Arduino "sketches" more closely than I'd done in the past I noted that they were quite "C"-like - albeit a rather limited one in many ways - but it looked like it might be useful when one just wanted to throw something together to do a particular function.

Programming in higher-level languages:

For some years now I've programmed PIC microcontrollers in C.  In using a higher level language, there's the risk of getting too far from the hardware and writing slow, bloated code, but frequently looking at the resulting assembly language can keep one grounded and aware of the sort of C code that will produce the best result.

Up to this point I've not gotten around to using an Arduino, but I did know about its sketch language and the relative convenience of dashing off some code and uploading it to the board.  This process and method has several downsides:
  • An Arduino is fairly expensive compared to just a "raw" microcontroller and the bare-minimum necessary parts.
  • If it's small, compact, fast code that you want, you might not use a high-level (ish) language.
A third point might be the fact that one is sort of straightjacketed by the physical aspect of the Arduino:  Whether you like it or not, any project built with or around it will have to conform it its layout and hardware limitations such as size and power consumption.

Having said all of that, it's very convenient to be able to buy lots of different plug-in accessories and boards for the Arduino family as well as use the vast, free libraries of shared code available for a wide variety of projects.  Not only that, there are a number of different Arduino variants about - both official and unofficial - that provide a lot of different hardware capabilities over a wide range of prices.

Making a shield:

So it came to be that a project came across that interested me - a means of effectively measuring the relative sensitivity of an optical receiver.  In this particular case Barry, G8AGN put together some code that generated a tone and then measured the analog signal from it in the presence and absence of that tone and then calculate the difference in deciBels.

Needing to interface an LCD to the Arduino I did not to have such an LCD "shield", the plug-in board that interfaces with the Arduino, as well as a bit of additional circuity.  Rummaging around in my parts bin I found all of the necessary pieces:  A small piece of perforated prototype board, some SIP headers, an HD44780-based LCD module and a few of the other miscellaneous parts.
Figure 1:
The bottom side of the constructed interface board (a.k.a. "Shield").
Click on the image for a larger version.

In lining up the pins of the SIP headers I noticed something that I'd not known before:  One of the four connectors on the board wasn't spaced in 0.1" (2.54mm) multiples from the other connectors in the "Y" axis.  In doing a bit of quick research on the GoogleFace (or is it the webTube?) the most credible reason for this was an error in the first run of the original Arduino boards due to a fast-approaching deadline.

How to work around this problem?

Fortunately, the pins were fairly long and I was able to bend a slight "dog leg" into each of the 10 pins of the that mate with the upper-right connector on the Arduino board - see Figure 2, below.

Figure 2:
A close-up of the pins (the 10 pins on the left) into which an offset was bent so that they would line up with the connector on the board.
Click on the image for a larger version.

While I was originally unsure if this would work, it was actually quite easy to put the bend in the leads - before soldering them to prevent tearing the etched copper ring from the board - using a pair of stout, fine-tipped needle-nose pliers.  Once the bends were made and I verified that the connectors mated properly I soldered the pins on the bottom side of the board to hold them in place.

On the top side of the board I'd used some solder-in pins with a plastic header, but instead of having a small portion of the pins stick below the board, I pushed the pins flush with the plastic headers and mounted them on the "top" (component side) of the board - see Figure 3, below.

Figure 3:
The operating and completed "shield".
Click on the image for a larger version.

As can be seen in Figure 3 the pins in the plastic headers are flush with the top and doing it this way adds mechanical support as all of the pins are secured from the top side as well as via the solder on the bottom side.  In soldering the connections to these pins, a bit of extra effort must be taken since there is limited room on the bottom side to do this, but it is certainly possible with a bit of care.

This seems to be a viable way to make interface boards of various sorts.  In the case of the above, I could have reduced it size to better-match that of the Arduino board by snapping off some of the extra pieces as well as positioning it over the board but with the rather large display I decided to keep it intact.

[End]

This page stolen from ka7oei.blogspot.com